Author Topic: Turn signal relay and wiring  (Read 492 times)

0 Members and 1 Guest are viewing this topic.

Offline MadMac66

  • Learning Your Way
  • *
  • Posts: 33
    • djelectricdaddy
    • View Profile
  • State: CA/USA
  • TV: 2007 Chevy Trailblazer
  • POP: 2004 Fleetwood Hemlock
Turn signal relay and wiring
« on: July 30, 2017, 02:36:33 PM »
 Hi guys

So one week before we head out on our first trip I realize that the turn signal that is not working was not due to a bad bulb. After testing and switching out three bulbs on both sides, it turns out the driver side turn signal has a fault in the wiring.

From what I can tell there is no relay on board, as the PUP signals blink in time with the truck signal, which leads me to believe everything is run off the truck relay.

So, how do I troubleshoot the wiring? How do I get to it? The tail light assembly panel is riveted - not screwed - to the body, so I can't remove and replace it. The wiring goes inside the hull, under the bed, and is hidden from any obvious access.

Obviously I have a few dats to get this fixed. I cannot head out with no turn signal. Any help or advice how to fix, or get to the wiring to troubleshoot, would be massively appreciated.

Thx
Adam

Offline MadMac66

  • Learning Your Way
  • *
  • Posts: 33
    • djelectricdaddy
    • View Profile
  • State: CA/USA
  • TV: 2007 Chevy Trailblazer
  • POP: 2004 Fleetwood Hemlock
Re: Turn signal relay and wiring
« Reply #1 on: July 30, 2017, 07:40:50 PM »
Okay, after a day of reading and watching and learning, followed by testing and measuring, here's what I have found.

Left and right turn signals, brake lights, tail lights and reverse lights all work on the Trailblazer. The boy problem is with driver side turn signal on the trailer.

Trailblazer has independent left and right fuse for trailer turn/brake lights. Was hoping this was the simple fix. Nope.

Tested voltage at the trailer connector on the truck, with the engine running:
Left brake - 14.2v
Right brake - 14.2v
Left signal - 13.9v
Right signal - 13.9v
Running lights - 14.1v
Reverse lights - 14.1v

I could not get a reading for the 12v positive connector, not sure what that means. But I guess I can rule out any problem stemming from the truck, connector or power supply side. Which means worse case scenario, the problem lies buried inside the guts of the trailer somewhere.

Again, any clues as how to even get access to troubleshoot this will be greatly welcomed

Thx
Adam

Offline MadMac66

  • Learning Your Way
  • *
  • Posts: 33
    • djelectricdaddy
    • View Profile
  • State: CA/USA
  • TV: 2007 Chevy Trailblazer
  • POP: 2004 Fleetwood Hemlock
Re: Turn signal relay and wiring
« Reply #2 on: July 30, 2017, 07:57:15 PM »
One more thing that occurred to me after a closer inspection. I have this little thing called a ShortStop (12v 15amp) that sits inline between battery negative and the breakaway box. Never heard any other trailer sites or YouTubers mention this thing. Could it be the cause of a bad ground?

Anyone hear of this or use it on their rig? Should I just remove it.

I cannot figure out where the ground connection is made to the trailer. Maybe it is underneath somewhere. There is obviously a ground coming from the 7-way connector, but surely it should screw into the chassis at some point.

Thx
Adam

https://www.dropbox.com/s/3jpucb38e8gn02w/Trailer%20wiring.jpeg?dl=0

Take a look at the attached photo and see if you can make sense of it.

Offline MadMac66

  • Learning Your Way
  • *
  • Posts: 33
    • djelectricdaddy
    • View Profile
  • State: CA/USA
  • TV: 2007 Chevy Trailblazer
  • POP: 2004 Fleetwood Hemlock
Re: Turn signal relay and wiring
« Reply #3 on: July 31, 2017, 05:02:20 PM »
Update. Tested voltage at the signal and it's getting 6.7v which is very odd.

Still have not found any idea how to get into the hull of the trailer to inspect the wiring. Got to be a short or bad ground buried in there somewhere.

Also figured out how to get the 12v to the connector, which allows the trailer battery to charge while driving. There is a fuse and stud that is not attached to the main 12v supply wire when it comes from the factory. They were good enough to provide the line and the fuse, but I just had to figure out where it was and how to hook it up. Thank you internet for that. So that means we can keep our fridge cold on our travel. Yippee

Any advice with the turn signal problem please really need some help

Offline Bad seed

  • Pretty Comfortable
  • *
  • Posts: 245
    • Rusty Klass
    • View Profile
  • State: PA/USA
  • TV: 2001 Ford Explorer
  • POP: 1996 Starcraft
Re: Turn signal relay and wiring
« Reply #4 on: July 31, 2017, 09:43:40 PM »
I think its a ground problem. Attach a new ground to the wire from somewhere else  and see if it fixes the problem. Also make sure both plugs a clean

 

Recent Topics

Equalizer hitch
by 2HappyCampers
[Yesterday at 08:02:53 PM]
Boulder Field / Lager Jogger Rally - April 2018
by chiefbowes
[October 20, 2017, 10:10:49 AM]
Summer on the Delaware
by 2HappyCampers
[October 19, 2017, 07:50:43 PM]
What's best to buy in the off season?
by thingette1
[October 18, 2017, 09:32:43 PM]
Stepping Out!
by thingette1
[October 18, 2017, 09:30:00 PM]
Towing with extra mirrors
by Ihearbanjos
[October 17, 2017, 06:20:50 PM]
Watkins Glen State Park - June 2018
by thingette1
[October 16, 2017, 06:19:42 PM]
CanvasCampers Rally History
by JoeCamper
[October 16, 2017, 05:25:21 AM]
Nov 2017 Thanksgiving Closer
by TMMull
[October 15, 2017, 10:18:20 AM]
Knoebels Fair and Funnel Cake Rally - Sept 2018
by Derryber
[October 13, 2017, 08:31:15 AM]
Haunted Halloween Rally - Oct 06-08th, 2017
by busdriverwc75
[October 12, 2017, 12:53:41 PM]
Fall Foliage 2018
by JoeCamper
[October 12, 2017, 12:33:16 PM]
Canvas repair and info
by 2HappyCampers
[October 10, 2017, 10:10:24 AM]
French Creek SP, PA - Season Opener Group Rally, March 2018
by vik-king
[October 06, 2017, 09:10:50 AM]
Pocono Raceway Nascar Camping
by chiefbowes
[October 05, 2017, 10:22:02 PM]